Routine maintenance for the Voice - EMEA, Frankfurt environment
Maintenance
upcoming
3 hours
2026-08-28T17:00:00.0000000Z
Routine maintenance for the Voice - EMEA, Frankfurt environment
Status: upcoming
Created:
2026-08-19T23:46:29.1630000Z
Start:
2026-08-28T17:00:00.0000000Z
Estimated Duration: 180 minutes
Affected Components:
Voice - EMEA, Frankfurt
Update
2026-08-28T17:00:00.0000000Z
2026-08-28T17:00:00.0000000Z
Medallia Mindful Callback will be performing routine maintenance on our Voice - EMEA, Frankfurt environment for 3h during the timeframe listed above. Please expect service disruptions during this time.
Copyright © 2026 Medallia.