Routine maintenance for Management Portal and the Voice -US East, US West, and LATAM environments
Maintenance
upcoming
3 hours
2026-08-28T02:00:00.0000000Z
Routine maintenance for Management Portal and the Voice -US East, US West, and LATAM environments
Status: upcoming
Created:
2026-08-19T23:45:02.6830000Z
Start:
2026-08-28T02:00:00.0000000Z
Estimated Duration: 180 minutes
Affected Components:
Management Portal
Voice - Americas, US East
Voice - Americas, US West
Voice - LATAM, São Paulo
Update
2026-08-28T02:00:00.0000000Z
2026-08-28T02:00:00.0000000Z
Medallia Mindful Callback will be performing routine maintenance on Management Portal and our Voice - Americas (US East), Voice - Americas (US West), and Voice - LATAM environments. Please expect service disruptions during this time.
Copyright © 2026 Medallia.