US West - Investigating Degraded Performance
Informational
2026-06-16T00:20:00.0000000Z
US West - Investigating Degraded Performance
Status: closed
Created:
2026-06-15T23:24:03.7230000Z
Date:
2026-06-15T22:00:00.0000000Z
Affected Components:
Voice - Americas, US West
Update
2026-06-15T22:00:00.0000000Z
2026-06-15T22:00:00.0000000Z
Mindful Callback is currently experiencing degraded performance. Our team is investigating and will provide updates as available.
Migration
2026-06-16T00:18:00.0000000Z
2026-06-16T00:18:00.0000000Z
Mindful Callback performance was fully restored at approx. 4:30p PT
An issue was identified by the Mindful Callback internal alerting showing degraded callback launching. The engineering team restarted all US West voice instances at approx. 3:45p PT to restore full functionality.
Copyright © 2026 Medallia.