Scheduled maintenance for Voice EMEA, Frankfurt / Voice APAC Sydney
Maintenance
upcoming
4 hours
2026-03-27T17:00:00.0000000Z
Scheduled maintenance for Voice EMEA, Frankfurt / Voice APAC Sydney
Status: upcoming
Created:
2026-03-19T19:31:06.3930000Z
Start:
2026-03-27T17:00:00.0000000Z
Estimated Duration: 240 minutes
Affected Components:
Voice - EMEA, Frankfurt
Voice - APAC, Sydney
Update
2026-03-27T17:00:00.0000000Z
2026-03-27T17:00:00.0000000Z
Medallia Mindful Callback will be performing routine maintenance on the following: Voice - EMEA, Frankfurt, Voice - APAC, Sydney for 4h during the timeframe listed above. We do not expect any impact to our users.
Copyright © 2026 Medallia.