Mindful Callback - Degraded Services Incident

Incident

Mindful Callback - Degraded Services Incident

Status: closed
Created:
Start:
End:
Duration: 3 hours 45 minutes
Affected Components:
Management Portal Insights API Notifications Datastore
Investigating

We are seeing users not able to load the Executive Summary report. We believe this to be related to a larger outage by our service provider; we are currently investigating the issue.

Identified

Mindful API, used for retrieving realtime statistics for Call Targets, is returning an Internal Server Error mesage. This and the previously identified issue with loading the Executive Summary are related to the larger outage by our service provider. We will continue to update when we have additional information.

Identified

We have not seen any issues registering or processing calls; however, we are seeing issues logging into our SSO enabled instance, sending notifications, and retrieving data from our Datastore. We will continue to update as we have more information.

Monitoring

We are starting to see improvements, we will continue to monitor.

Resolved

We've confirmed restored functionality. Over the next few days, we will continue to ensure the integrity of the historical records during this window, but we are considering this incident resolved.