Mindful Insights - Historical metrics Delayed Processing

Incident

Mindful Insights - Historical metrics Delayed Processing

Status: closed
Created:
Start:
End:
Duration: 1 day 19 hours 37 minutes
Affected Components:
Insights API
Identified

An upstream cloud provider is experiencing service degradation which is causing Mindful's historical reporting to be inaccurate. There is no data loss at this time, however, the processing of the data has been delayed. Historical reports in Mindful Insights, as well as the historical reporting available via Mindful API could be affected. We will continue to monitor the situation and provide updates as necessary.

Monitoring

We continue to monitor the situation. The Mindful team has tested the environment health, reporting no functionality issues and only report a potential issue with accuracy of the historical reporting data. We will continue to update until resolved

Monitoring

The upstream cloud provider has resolved the issue. The Mindful team is coordinating steps to re-process potential missing historical data today.

Monitoring

The Mindful team has begun re-processing the historical data to recover any missed during the service degradation. This is expected to continue throughout the remainder of today and this evening. Further updates will be posted when process is complete.

Monitoring

At this time, some of the historical data processing has completed. A small number of clients data, those clients that are on callback.mindful.cx, has yet to be reprocessed for the affected time period. In order to reprocess the remaining data successfully, we need to apply a small change to ensure that data is accurately reprocessed for this environment. We will provide another update again tomorrow (8/1/24) with the status of that change and of the data reprocessing for those clients.

Resolved

All processes to retrieve any missed historical data has completed. This issue is considered resolved